UK-Muscle.co.uk Forum banner
1 - 7 of 7 Posts

·
Premium Member
Joined
·
161 Posts
Discussion Starter · #1 ·
so been running t 400 for about 16 weeks now and about 1 month ago start getting libido issues feeling very unmotivated etc so decided to get some bloods done , did also get my blood done from doctors to check cholesterol cholesterol thyroid etc came back fine so just unsure as to why the problem could be considering I’ve never had this problem before anyone point me in the right direction ?
 

Attachments

·
Premium Member
Joined
·
161 Posts
Discussion Starter · #3 ·
Lifestyle related in all likelihood. Is your e2 where it has been previously when things are ok?
I did think that tbh as I work 7 days a week so was putting it down to maybe just been tired but normally I’ve never had that issue before so was quite strange especially since bloods doesn’t look that bad and all my health checks at doctors were fine.
 

·
Premium Member
Joined
·
161 Posts
Discussion Starter · #7 ·
If we do 400 mg of test e we should get around 120-160 nmol however if you have a mix blend like undeconate in there the release time will be slow to build up. Maybe it could be that but I am unsure of your blends
No idea what it is mate got no description on the website either just says 400, think it’s worth switching to something else ?
 

·
Premium Member
Joined
·
161 Posts
Discussion Starter · #9 ·
If that’s your reading snd you want to put size on your best to have around 160 nmol but depending on steroid experience, experiment, goals. I recon the 400 test has undeconate/deconate which takes time to build up. 60 nmol for me will normally be 200 mg of testosterone. Nexus do dose correctly I’ve tested them myself. If you did a finger blood test then make sure you do a vein test. This will give a more accurate reading.
I’ve always used nexus and always felt good on it just obv with libido been non existent thought it was high e2 or maybe underdosed , doctor obv said come off cycle it’s that causing the problem but by blood work a can’t see how .
 

·
Premium Member
Joined
·
161 Posts
Discussion Starter · #13 ·
How long after injection did you pull bloods?
Jabbed on a weekend done the bloods on a wednesday.
E2 is high but this is not a usual problem when your testosterone is twice the range as rally healthy normal ranges. How many weeks you been on this cycle, what ai are you using, when did you draw blood after your injection ?

Don’t stress there is a couple of things to try and more things to figure out.
don’t really use an ai unless I go over 500mg tbh but since a started getting problems a started using 0.5 Adex twice a week. The whole course was 16 weeks so far I ran tren for the first 8 for my holiday which was 200mg but since I always had problems with tren I ran caber at 0.5 mg twice a week I did see on my blood my prolactin was low but surely it can’t stay that low for like a month ?
 

·
Premium Member
Joined
·
161 Posts
Discussion Starter · #19 ·
I do not know how caber works in terms of a real life experiment. When I advise I usually advise from my own experiment or from what I’ve seen and heard from others with caution. I only advise from lads I know personally and not parrot from a forum.

Your e2 is not that far out of the normal range you could maybe add 0.25 arimidex only for a few weeks to see how you feel. If this does not work then get blood work done to check prolactin and e2 again then post your situation up.
Cheers mate that’s what a done taking 0.5 adex for couple of weeks then all get blood checked again in about 2 weeks see where the prolactin and e2 is , was just abit daft on cycle trying to self medicate without blood work tbh I thought prolactin was high because of the tren so was taking caber when all along my e2 was probz abit high and my prolactin was low , live and learn tho that’s why ya always get blood tests .
 
1 - 7 of 7 Posts
Top